Debian 6.0 (squeeze)でWordPress3.5を使う その1: 調査と準備編

Tablet PC deals and Promotion
調査

前回はnginxを最新に更新しました。

今度はWordPressを3.3.xから3.5.xに更新したいと思います。

実は以前にWordPress 3.0.xを強引に3.3.xに更新したことがあります(その1, その2, その3)。結果的にセキュリティーアップデートが出て簡単に3.3.xに更新できるようになったのですが、今回は前回の強引な手法(?)を踏襲します。

DebianのWordPressパッケージの状況

下記のURIにアクセスしてDebianのWordPressパッケージの状況を見てみます。

DebianのWordPressパッケージ

squeeze(すでにoldstable)は3.3.2で、squeezeの次の安定版wheezyだと3.5.1が使えることがわかります。

Debian 7.0(wheezy)のパッケージを流用

今回はこのwheezy(= Debian 7.0)のパッケージを流用にチャレンジしてみます。

必要なパッケージ情報の収集

まずは、Debian 7.0(wheezy)用のwordpressパッケージの情報を入手します。情報はhttp://packages.debian.org/wheezy/wordpressで表示されます。

重要なのは赤丸+”dep”で示されたパッケージです。これらのパッケージがインストールされていないと、WordPressパッケージも動きません。私が調べた状態ではWordPressの依存関係は次の通りでした。

  • dpkg (>= 1.15.7.2)
  • apache2 or httpd
  • libapache2-mod-php5 or php
  • libjs-cropper (>= 1.2.2)
  • libphp-phpmailer (>= 5.1)
  • libphp-snoopy (>= 1.2.4)
  • mysql-client
  • php5-gd
  • php5-mysql
  • tinymce (<< 3.4.8+dfsg0.0~)

バージョンが指定されているパッケージに関してはインストールしているバージョンを確認していきます。確認は

# dpkg –l | grep パッケージ名

で行います。

調査の結果、私の環境では次のようになりました。

  • dpkg : 1.15.8.13 ⇒ OK
  • libjs-cropper : 1.2.2-1  ⇒ OK
  • libphp-phpmailer : 5.1-1 ⇒ OK
  • libphp-snoopy : 1.2.4-2 ⇒ OK
  • tinymce : 私の環境にはインストールされておらず

tinymceについては「apt-get install tinymce」を実行すると「 3.3.8+dfsg0-0.1」というバージョンがインストールされたのでこれで問題ないようです。

Debian 7.0(wheezy)用パッケージ入手の準備

運よくパッケージの依存関係には問題がなさそうなので、あとはwheezyのパッケージが入手できる除隊とすればよいことになります。

このためにはまず次の内容のファイルを/etc/apt/sources.list.d/ディレクトリに「wheezy.list」というファイル名で作ります。

deb http://ftp.jp.debian.org/debian wheezy main contrib non-free
deb-src http://ftp.jp.debian.org/debian wheezy main contrib non-free

次に/etc/apt/preferences.d/ディレクトリにファイル名「00wheezy」で次の内容のファイルを作ります。

Package: *
Pin: release a=wheezy
Pin-Priority: 110
 
Package: *
Pin: release a=squeeze
Pin-Priority: 990

ここまで準備できたらAPTITUDEコマンドでパッケージ情報を更新します。

aptitude update

パッケージ情報の更新を完了したらWordPressパッケージの情報を確認します。下記のようになっているはずです。

aptitude versions wordpress wordpress-l10n
Package wordpress:
i   3.3.2+dfsg-1~squeeze1                         oldstable                 500
p   3.5.1+dfsg-2                                  stable                    500

Package wordpress-l10n:
i A 3.3.2+dfsg-1~squeeze1                         oldstable                 500
p A 3.5.1+dfsg-2                                  stable                    500

まとめ

Debian 7.0 (wheezy)のWordPressパッケージ(バージョン3.3.x)を使う準備が整いました。

次回は万が一のためにWordPressのデータをバックアップします。